package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/[a-zA-Z0-9]+((?:-+|\/)(?:[a-zA-Z0-9]+))*(\.(?:jpe?g|gif|png|html?))?$`)
var str = `/test/test.htm
/test/test
/test/test-test.htm
/test/test-test
/test/test-test/test/test
/test-test/test-test/test-test
/test-test/test-test/test--test
/test/test123.htm
/test/test-
/test/test123/test/.html
/test/test.
/test/.hhh
/tes t
/tes_t
/tes"t
/tes’t
/-test
//test/test123/test/.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}