$re = '/^\/[a-zA-Z0-9]+((?:-+|\/)(?:[a-zA-Z0-9]+))*(\.(?:jpe?g|gif|png|html?))?$/m';
$str = '/test/test.htm
/test/test
/test/test-test.htm
/test/test-test
/test/test-test/test/test
/test-test/test-test/test-test
/test-test/test-test/test--test
/test/test123.htm
/test/test-
/test/test123/test/.html
/test/test.
/test/.hhh
/tes t
/tes_t
/tes"t
/tes’t
/-test
//test/test123/test/.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);