// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/[a-zA-Z0-9]+((?:-+|\/)(?:[a-zA-Z0-9]+))*(\.(?:jpe?g|gif|png|html?))?$").unwrap();
let string = "/test/test.htm
/test/test
/test/test-test.htm
/test/test-test
/test/test-test/test/test
/test-test/test-test/test-test
/test-test/test-test/test--test
/test/test123.htm
/test/test-
/test/test123/test/.html
/test/test.
/test/.hhh
/tes t
/tes_t
/tes\"t
/tes’t
/-test
//test/test123/test/.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}