import re
regex = re.compile(r"^\/[a-zA-Z0-9]+((?:-+|\/)(?:[a-zA-Z0-9]+))*(\.(?:jpe?g|gif|png|html?))?$", flags=re.MULTILINE)
test_str = ("/test/test.htm\n"
"/test/test\n"
"/test/test-test.htm\n"
"/test/test-test\n"
"/test/test-test/test/test\n"
"/test-test/test-test/test-test\n"
"/test-test/test-test/test--test\n"
"/test/test123.htm\n\n"
"/test/test-\n"
"/test/test123/test/.html\n"
"/test/test.\n"
"/test/.hhh\n"
"/tes t\n"
"/tes_t\n"
"/tes\"t\n"
"/tes’t\n"
"/-test\n"
"//test/test123/test/.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")