using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+\([^\)]+\)|\S+(?!\())";
string input = @"VALUE1 PARAMETER(VALUE2)
VALUE3 PARAMETER(VALUE4 WITH SPACES)
PARAMETER(VALUE5) VALUE6
PARAMETER(VALUE7 WITH SPACES) VALUE8
PARAMETER(VALUE9 WITH SPACES) PARAMETER(VALUE10)
VALUE11 VALUE12
PARAMETER(VALUE13 WITH SPACES)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}