use strict;
my $str = 'VALUE1 PARAMETER(VALUE2)
VALUE3 PARAMETER(VALUE4 WITH SPACES)
PARAMETER(VALUE5) VALUE6
PARAMETER(VALUE7 WITH SPACES) VALUE8
PARAMETER(VALUE9 WITH SPACES) PARAMETER(VALUE10)
VALUE11 VALUE12
PARAMETER(VALUE13 WITH SPACES)';
my $regex = qr/(\S+\([^\)]+\)|\S+(?!\())/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}