$re = '/(\S+\([^\)]+\)|\S+(?!\())/';
$str = 'VALUE1 PARAMETER(VALUE2)
VALUE3 PARAMETER(VALUE4 WITH SPACES)
PARAMETER(VALUE5) VALUE6
PARAMETER(VALUE7 WITH SPACES) VALUE8
PARAMETER(VALUE9 WITH SPACES) PARAMETER(VALUE10)
VALUE11 VALUE12
PARAMETER(VALUE13 WITH SPACES)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);