import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+\\([^\\)]+\\)|\\S+(?!\\())";
final String string = "VALUE1 PARAMETER(VALUE2)\n"
+ "VALUE3 PARAMETER(VALUE4 WITH SPACES)\n"
+ "PARAMETER(VALUE5) VALUE6\n"
+ "PARAMETER(VALUE7 WITH SPACES) VALUE8\n"
+ "PARAMETER(VALUE9 WITH SPACES) PARAMETER(VALUE10)\n"
+ "VALUE11 VALUE12 \n"
+ "PARAMETER(VALUE13 WITH SPACES)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}