#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/column\/mania-\b(?!list)(.*))"
Local $sString = "/column/mania-list" & @CRLF & _
"/column/mania-001" & @CRLF & _
"/column/mania-003" & @CRLF & _
"/column/mania-test" & @CRLF & _
"" & @CRLF & _
"/contents/truck-show" & @CRLF & _
"" & @CRLF & _
"/column/makers-007" & @CRLF & _
"/column/makers-list" & @CRLF & _
"/column/makers-001" & @CRLF & _
"/column/makers-test" & @CRLF & _
"" & @CRLF & _
"/column/craftman-list" & @CRLF & _
"/column/craftman-008" & @CRLF & _
"/column/craftman-001" & @CRLF & _
"/column/craftman-asf" & @CRLF & _
"" & @CRLF & _
"/column/jobcolumn-074" & @CRLF & _
"/column/jobcolumn-098" & @CRLF & _
"/column/jobcolumn-098" & @CRLF & _
"/column/jobcolumn-list" & @CRLF & _
"" & @CRLF & _
"/column/job-skill-016" & @CRLF & _
"/column/job-skill-test" & @CRLF & _
"/column/job-skill-list" & @CRLF & _
"/column/job-skill-054" & @CRLF & _
"/column/job-skill-016" & @CRLF & _
"" & @CRLF & _
"/column/work-laboratory-list" & @CRLF & _
"/column/work-laboratory-039" & @CRLF & _
"/column/work-laboratory-test" & @CRLF & _
"" & @CRLF & _
"/column/watashi-yorokobi/sskonomi-suzuki" & @CRLF & _
"/column/watashi-yorokobi/eri-tokunaga" & @CRLF & _
"/column/watashi-yorokobi" & @CRLF & _
"/column/watashi-yorokobi/lully-miura" & @CRLF & _
"" & @CRLF & _
"/column/town-navigation-list" & @CRLF & _
"/column/town-navigation-050" & @CRLF & _
"/column/town-navigation-lisd" & @CRLF & _
"/column/town-navigation-test" & @CRLF & _
"" & @CRLF & _
"/column/cartoon-002" & @CRLF & _
"/column/cartoon-001" & @CRLF & _
"/column/cartoon-2fe" & @CRLF & _
"/column/cartoon-list" & @CRLF & _
"" & @CRLF & _
"/contents/glossary" & @CRLF & _
"" & @CRLF & _
"/column/toyota-seisan-023" & @CRLF & _
"/column/toyota-seisan-021" & @CRLF & _
"/column/toyota-seisan-020" & @CRLF & _
"/column/toyota-seisan-aasdss" & @CRLF & _
"/column/toyota-seisan-list"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")