# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/column\/mania-\b(?!list)(.*))"
test_str = ("/column/mania-list\n"
"/column/mania-001\n"
"/column/mania-003\n"
"/column/mania-test\n\n"
"/contents/truck-show\n\n"
"/column/makers-007\n"
"/column/makers-list\n"
"/column/makers-001\n"
"/column/makers-test\n\n"
"/column/craftman-list\n"
"/column/craftman-008\n"
"/column/craftman-001\n"
"/column/craftman-asf\n\n"
"/column/jobcolumn-074\n"
"/column/jobcolumn-098\n"
"/column/jobcolumn-098\n"
"/column/jobcolumn-list\n\n"
"/column/job-skill-016\n"
"/column/job-skill-test\n"
"/column/job-skill-list\n"
"/column/job-skill-054\n"
"/column/job-skill-016\n\n"
"/column/work-laboratory-list\n"
"/column/work-laboratory-039\n"
"/column/work-laboratory-test\n\n"
"/column/watashi-yorokobi/sskonomi-suzuki\n"
"/column/watashi-yorokobi/eri-tokunaga\n"
"/column/watashi-yorokobi\n"
"/column/watashi-yorokobi/lully-miura\n\n"
"/column/town-navigation-list\n"
"/column/town-navigation-050\n"
"/column/town-navigation-lisd\n"
"/column/town-navigation-test\n\n"
"/column/cartoon-002\n"
"/column/cartoon-001\n"
"/column/cartoon-2fe\n"
"/column/cartoon-list\n\n"
"/contents/glossary\n\n"
"/column/toyota-seisan-023\n"
"/column/toyota-seisan-021\n"
"/column/toyota-seisan-020\n"
"/column/toyota-seisan-aasdss\n"
"/column/toyota-seisan-list")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.