import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/column\\/mania-\\b(?!list)(.*))";
final String string = "/column/mania-list\n"
+ "/column/mania-001\n"
+ "/column/mania-003\n"
+ "/column/mania-test\n\n"
+ "/contents/truck-show\n\n"
+ "/column/makers-007\n"
+ "/column/makers-list\n"
+ "/column/makers-001\n"
+ "/column/makers-test\n\n"
+ "/column/craftman-list\n"
+ "/column/craftman-008\n"
+ "/column/craftman-001\n"
+ "/column/craftman-asf\n\n"
+ "/column/jobcolumn-074\n"
+ "/column/jobcolumn-098\n"
+ "/column/jobcolumn-098\n"
+ "/column/jobcolumn-list\n\n"
+ "/column/job-skill-016\n"
+ "/column/job-skill-test\n"
+ "/column/job-skill-list\n"
+ "/column/job-skill-054\n"
+ "/column/job-skill-016\n\n"
+ "/column/work-laboratory-list\n"
+ "/column/work-laboratory-039\n"
+ "/column/work-laboratory-test\n\n"
+ "/column/watashi-yorokobi/sskonomi-suzuki\n"
+ "/column/watashi-yorokobi/eri-tokunaga\n"
+ "/column/watashi-yorokobi\n"
+ "/column/watashi-yorokobi/lully-miura\n\n"
+ "/column/town-navigation-list\n"
+ "/column/town-navigation-050\n"
+ "/column/town-navigation-lisd\n"
+ "/column/town-navigation-test\n\n"
+ "/column/cartoon-002\n"
+ "/column/cartoon-001\n"
+ "/column/cartoon-2fe\n"
+ "/column/cartoon-list\n\n"
+ "/contents/glossary\n\n"
+ "/column/toyota-seisan-023\n"
+ "/column/toyota-seisan-021\n"
+ "/column/toyota-seisan-020\n"
+ "/column/toyota-seisan-aasdss\n"
+ "/column/toyota-seisan-list";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}