using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/column\/mania-\b(?!list)(.*))";
string input = @"/column/mania-list
/column/mania-001
/column/mania-003
/column/mania-test
/contents/truck-show
/column/makers-007
/column/makers-list
/column/makers-001
/column/makers-test
/column/craftman-list
/column/craftman-008
/column/craftman-001
/column/craftman-asf
/column/jobcolumn-074
/column/jobcolumn-098
/column/jobcolumn-098
/column/jobcolumn-list
/column/job-skill-016
/column/job-skill-test
/column/job-skill-list
/column/job-skill-054
/column/job-skill-016
/column/work-laboratory-list
/column/work-laboratory-039
/column/work-laboratory-test
/column/watashi-yorokobi/sskonomi-suzuki
/column/watashi-yorokobi/eri-tokunaga
/column/watashi-yorokobi
/column/watashi-yorokobi/lully-miura
/column/town-navigation-list
/column/town-navigation-050
/column/town-navigation-lisd
/column/town-navigation-test
/column/cartoon-002
/column/cartoon-001
/column/cartoon-2fe
/column/cartoon-list
/contents/glossary
/column/toyota-seisan-023
/column/toyota-seisan-021
/column/toyota-seisan-020
/column/toyota-seisan-aasdss
/column/toyota-seisan-list";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}