# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|{(?=[a-f\d]{8}(?:_[a-f\d]{4}){4}[a-f\d]{8}\}))[a-f\d]*\K_/-/gmi;t' <<< "89695C16_C0FF_4E7C_9BB2_8B50FAC9D371
{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}"