import re
regex = re.compile(r"(?:\G(?!\A)|{(?=[a-f\d]{8}(?:_[a-f\d]{4}){4}[a-f\d]{8}\}))[a-f\d]*\K_", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("89695C16_C0FF_4E7C_9BB2_8B50FAC9D371\n"
"{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)