$re = '/(?:\G(?!\A)|{(?=[a-f\d]{8}(?:_[a-f\d]{4}){4}[a-f\d]{8}\}))[a-f\d]*\K_/mi';
$str = '89695C16_C0FF_4E7C_9BB2_8B50FAC9D371
{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;