use strict;
my $str = '89695C16_C0FF_4E7C_9BB2_8B50FAC9D371
{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}';
my $regex = qr/(?:\G(?!\A)|{(?=[a-f\d]{8}(?:_[a-f\d]{4}){4}[a-f\d]{8}\}))[a-f\d]*\K_/mip;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";