#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<html>.*?<head>.*?<title>.*?<\/title>.*?<\/head>.*?<body[^>]*>.*?<\/body>.*?<\/html>"
Local $sString = "<html>.*?<head>.*?<title>.*?</title>.*?</head>.*?<body1><body2><body3><body4><body5>.*?</body>.*?</html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")