$re = '/<html>.*?<head>.*?<title>.*?<\/title>.*?<\/head>.*?<body[^>]*>.*?<\/body>.*?<\/html>/m';
$str = '<html>.*?<head>.*?<title>.*?</title>.*?</head>.*?<body1><body2><body3><body4><body5>.*?</body>.*?</html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);