re = /<html>.*?<head>.*?<title>.*?<\/title>.*?<\/head>.*?<body[^>]*>.*?<\/body>.*?<\/html>/m
str = '<html>.*?<head>.*?<title>.*?</title>.*?</head>.*?<body1><body2><body3><body4><body5>.*?</body>.*?</html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end