import re
regex = re.compile(r"<html>.*?<head>.*?<title>.*?<\/title>.*?<\/head>.*?<body[^>]*>.*?<\/body>.*?<\/html>", flags=re.MULTILINE)
test_str = "<html>.*?<head>.*?<title>.*?</title>.*?</head>.*?<body1><body2><body3><body4><body5>.*?</body>.*?</html"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")