#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{4}([.\-/ ])\d{2}\2\d{2}|\d{2}([.\-/ ])\d{2}\3\d{4})"
Local $sString = "Leider hat sich der Mitarbeiter Max Mustermann, der am 03.01.2022 eingestellt wurde, aus verschiedenen Gründen entschlossen, seine Tätigkeit bei uns zu beenden. Wir möchten Sie über die Situation informieren 02.21.1234 und fragen, wie wir in diesem Fall vorgehen sollen?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")