const regex = new RegExp('(\\d{4}([.\\-/ ])\\d{2}\\2\\d{2}|\\d{2}([.\\-/ ])\\d{2}\\3\\d{4})', '')
const str = `Leider hat sich der Mitarbeiter Max Mustermann, der am 03.01.2022 eingestellt wurde, aus verschiedenen Gründen entschlossen, seine Tätigkeit bei uns zu beenden. Wir möchten Sie über die Situation informieren 02.21.1234 und fragen, wie wir in diesem Fall vorgehen sollen?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}