use strict;
my $str = 'Leider hat sich der Mitarbeiter Max Mustermann, der am 03.01.2022 eingestellt wurde, aus verschiedenen Gründen entschlossen, seine Tätigkeit bei uns zu beenden. Wir möchten Sie über die Situation informieren 02.21.1234 und fragen, wie wir in diesem Fall vorgehen sollen?';
my $regex = qr/(\d{4}([.\-/ ])\d{2}\2\d{2}|\d{2}([.\-/ ])\d{2}\3\d{4})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}