using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}([.\-/ ])\d{2}\2\d{2}|\d{2}([.\-/ ])\d{2}\3\d{4})";
string input = @"Leider hat sich der Mitarbeiter Max Mustermann, der am 03.01.2022 eingestellt wurde, aus verschiedenen Gründen entschlossen, seine Tätigkeit bei uns zu beenden. Wir möchten Sie über die Situation informieren 02.21.1234 und fragen, wie wir in diesem Fall vorgehen sollen?";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}