import re
regex = re.compile(r"(?<=[^\w\s])\s+", flags=re.MULTILINE)
test_str = ("hello there, how are you doing?\n"
"Hi! I got a new product for you. Would you like to know more?\n"
"It's Taco Tuesday man")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")