package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\['key_to_search_for'\]\['post_date'\] = '(\d{1,2} \w+ \w+)';$`)
var str = `['key_to_search_for']['post_date'] = '10 days ago';
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}