$re = '/^\[\'key_to_search_for\'\]\[\'post_date\'\] = \'(\d{1,2} \w+ \w+)\';$/m';
$str = '[\'key_to_search_for\'][\'post_date\'] = \'10 days ago\';
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);