re = /^\['key_to_search_for'\]\['post_date'\] = '(\d{1,2} \w+ \w+)';$/m
str = '[\'key_to_search_for\'][\'post_date\'] = \'10 days ago\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end