package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^([\S]+)([ ])([\S]+)([ ])([\w\d]+)|^(.*)|^(.*)(.*))`)
var str = `asfdf as fsad f sa
fma9 j23489 rz2398 rz23 97úú
va h89 3zr1q e 3pőü1 ru3
39öa4ghaö8zaígvnydpvjydöi fuwa89ö fuaw sdf sad sd sdf sd fa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}