re = /(^([\S]+)([ ])([\S]+)([ ])([\w\d]+)|^(.*)|^(.*)(.*))/m
str = 'asfdf as fsad f sa
fma9 j23489 rz2398 rz23 97úú
va h89 3zr1q e 3pőü1 ru3
39öa4ghaö8zaígvnydpvjydöi fuwa89ö fuaw sdf sad sd sdf sd fa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end