import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([\\S]+)([ ])([\\S]+)([ ])([\\w\\d]+)|^(.*)|^(.*)(.*))";
final String string = "asfdf as fsad f sa\n"
+ "fma9 j23489 rz2398 rz23 97úú\n"
+ "va h89 3zr1q e 3pőü1 ru3\n"
+ "39öa4ghaö8zaígvnydpvjydöi fuwa89ö fuaw sdf sad sd sdf sd fa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}