package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d*(\,[1-9]\d*)*$`)
var str = `1,2,3,4,5
,1,2,3,4
10,2,3,4,5
01,2,3,4,5
1,02,3,4,5
1,2,3,4,5,
1,,02,3,4
01
01,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}