// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]\d*(\,[1-9]\d*)*$").unwrap();
let string = "1,2,3,4,5
,1,2,3,4
10,2,3,4,5
01,2,3,4,5
1,02,3,4,5
1,2,3,4,5,
1,,02,3,4
01
01,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}