re = /^[1-9]\d*(\,[1-9]\d*)*$/m
str = '1,2,3,4,5
,1,2,3,4
10,2,3,4,5
01,2,3,4,5
1,02,3,4,5
1,2,3,4,5,
1,,02,3,4
01
01,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end