# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\w]df\./kkk./g;t' <<< "asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka"