package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w]df\.`)
var str = `asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka`
var substitution = "kkk."
fmt.Println(re.ReplaceAllString(str, substitution))
}