const regex = /[^\w]df\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\w]df\\.', 'g')
const str = `asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka`;
const subst = `kkk.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);