use strict;
my $str = 'asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka';
my $regex = qr/[^\w]df\./p;
my $subst = 'kkk.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";