import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-z0-9._%+-]+@[^,\\s]*";
final String string = "(14.2) 04-01-18 00:03:38 (1944:3676) PRINTFN: $G_NOTIFY_GRP_INTERNAL: peter.parker@abc.com,thomas.holland03@abc.com \n"
+ "(14.2) 04-01-18 04:14:38 (5796:5968) PRINTFN: $G_NOTIFY_GRP_INTERNAL: henry.pete@abc.com,grant.subarao@abc.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}