$re = '/[A-z0-9._%+-]+@[^,\s]*/m';
$str = '(14.2) 04-01-18 00:03:38 (1944:3676) PRINTFN: $G_NOTIFY_GRP_INTERNAL: peter.parker@abc.com,thomas.holland03@abc.com
(14.2) 04-01-18 04:14:38 (5796:5968) PRINTFN: $G_NOTIFY_GRP_INTERNAL: henry.pete@abc.com,grant.subarao@abc.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);