use strict;
my $str = '(14.2) 04-01-18 00:03:38 (1944:3676) PRINTFN: $G_NOTIFY_GRP_INTERNAL: peter.parker@abc.com,thomas.holland03@abc.com
(14.2) 04-01-18 04:14:38 (5796:5968) PRINTFN: $G_NOTIFY_GRP_INTERNAL: henry.pete@abc.com,grant.subarao@abc.com';
my $regex = qr/[A-z0-9._%+-]+@[^,\s]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}