const regex = /[A-z0-9._%+-]+@[^,\s]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-z0-9._%+-]+@[^,\\s]*', 'gm')
const str = `(14.2) 04-01-18 00:03:38 (1944:3676) PRINTFN: \$G_NOTIFY_GRP_INTERNAL: peter.parker@abc.com,thomas.holland03@abc.com
(14.2) 04-01-18 04:14:38 (5796:5968) PRINTFN: \$G_NOTIFY_GRP_INTERNAL: henry.pete@abc.com,grant.subarao@abc.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}