package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\+\*!,\.-a-zA-Z0-9_\s&\w]* Copyright (©|\(C\)) \d{4} COMPANYNAME [&a-zA-Z0-9_\s,\.]*`)
var str = `// Copyright © 2019 COMPANYNAME All rights reserved.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}