$re = '/[\+\*!,\.-a-zA-Z0-9_\s&\w]* Copyright (©|\(C\)) \d{4} COMPANYNAME [&a-zA-Z0-9_\s,\.]*/m';
$str = '// Copyright © 2019 COMPANYNAME All rights reserved.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);