import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'string1[^']*'\\s*,\\s*";
final String string = "['string1','string2','string3']\n"
+ "['string1' , 'string2' , 'string3']\n"
+ "['string1.domain.com' , 'string2.domain.com' , 'string3.domain.com']\n"
+ "['string1.domain.com:8080' , 'string2.domain.com:8080' , 'string3.domain.com:8080']";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}