re = /'string1[^']*'\s*,\s*/
str = '[\'string1\',\'string2\',\'string3\']
[\'string1\' , \'string2\' , \'string3\']
[\'string1.domain.com\' , \'string2.domain.com\' , \'string3.domain.com\']
[\'string1.domain.com:8080\' , \'string2.domain.com:8080\' , \'string3.domain.com:8080\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end