import re
regex = re.compile(r"'string1[^']*'\s*,\s*")
test_str = ("['string1','string2','string3']\n"
"['string1' , 'string2' , 'string3']\n"
"['string1.domain.com' , 'string2.domain.com' , 'string3.domain.com']\n"
"['string1.domain.com:8080' , 'string2.domain.com:8080' , 'string3.domain.com:8080']")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")