$re = '/\'string1[^\']*\'\s*,\s*/';
$str = '[\'string1\',\'string2\',\'string3\']
[\'string1\' , \'string2\' , \'string3\']
[\'string1.domain.com\' , \'string2.domain.com\' , \'string3.domain.com\']
[\'string1.domain.com:8080\' , \'string2.domain.com:8080\' , \'string3.domain.com:8080\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);