#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S+)(?:)*.CITIBANK"
Local $sString = "Also see attached letter for and CITIBANK" & @CRLF & _
"Also see attached letter for ad CITIBANK" & @CRLF & _
"Also see attached letter for an CITIBANK" & @CRLF & _
"Also see attached letter for nd CITIBANK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")