package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)(?:)*.CITIBANK`)
var str = `Also see attached letter for and CITIBANK
Also see attached letter for ad CITIBANK
Also see attached letter for an CITIBANK
Also see attached letter for nd CITIBANK`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}